Jump to content
Sign in to follow this  
Tigerfreund

Sound-Ansteuerung

Recommended Posts

Tigerfreund

Hallo Kollegen,

 

für meine Bernhard Gruben habe mich mir das Soundmodul des Modellbaukaufhaus (von LE-Elektronik) geleistet. Die Motorengeräusche funktionieren auch recht gut, aber mit den Zusatzgeräuschen habe ich meine Probleme. Angesteuert werden die Geräusche über die Herstellung einer Verbindung der jeweiligen Geräuschleitung zu einem Massekabel. Eine kurze Verbindung genügt um dem Sound zu starten. Also habe ich 2 Schalter für die Ablassen und das Schließen der Heckklappe (sind 2 verschiedene Sounds) eingebaut an den Servohebel angebaut, aber je länger ich darüber nachdenke desto mehr wird mir klar, dass das eigentlich gar nicht richtig klappen kann.

 

Eine elektronische Anschaltung über ein Servo-Parallelkabel hat bis jetzt auch noch nichts gebracht. Das zugekaufte Schaltmodul schaltet entweder gar nicht, oder immer.

 

Hat jemand das Modul eingebaut und kann mir ein paar Tipps geben, oder hat jemand einen guten Vorschlag für einen Elektroniklaien?

 

Viele Grüße

Ralf

Share this post


Link to post
rc-radi

Hallo Ralf --

 

-- ich würde mich mit Herrn Eberstein (LE-Elektronik) in Verbindung setzen, denn er kann dir bestimmt weiter helfen !

 

Ich hatte vor ca. 6 Monaten das Vergnügen mit ihm zu telefonieren, und ich muss sagen dass er sehr freundlich und zuvorkommend ist, wenn du Probleme hast...und er hilft auch wo er kann !! :that:

 

Am besten du rufst ihn mal an.... ;)

 

---------------

 

Edit: Also für mich kommt kein anderes Soundmodul (mehr) in Frage, da die Sounds auf Originalaufnahmen basieren !!!

Bei anderen Herstellern werden die Sounds doch nur elektronisch "hochgepusht".....:nein:

Hört euch mal die Sounds der anderen genau an.....:(

Edited by rc-radi

Share this post


Link to post
MatthiasSchumi

Hallo Ralf,

zwei Hinweise von mir:

Hast Du die Ansteuerung der Zusatzgeräusche mal mit ner Litze ohne den Aufbau mit Servo und so probiert?

Ansonsten kann ich den Hinweis auf die tolle Unterstützung von Hr. Eberstein nur bestätigen. Mein erstes Modul hat mir auch ein wenig Probleme mit der Inbetriebnahme gemacht, aber dann klappte es nach dem Telefonat bestens.

Share this post


Link to post
rc-radi

Ansonsten kann ich den Hinweis auf die tolle Unterstützung von Hr. Eberstein nur bestätigen.

 

Vor allem schafft es Herr Eberstein bei div. Sounds die nicht den vollen Umfang errreichen sollen, z.B. bei Motorensound, nur die halbe Drehzahl akustisch rüber zu bringen bzw. aufzuspielen !

 

Ich habe mir so eine Option für mein ausgesuchtes Modul mal als Minifile zusenden lassen...... einfach nur genial ... :that::that: !!

Share this post


Link to post
Kapitän Odin

Hallo Ralf,

 

dann will ich auch mal mein Senpf dazu tun :D

 

Seiner Zeit habe ich für meine Smit Bronco auch ein Sound Modul gesucht,

RC Radi verwiss mich eben falls zu LE Elektonik, Bei einem Telefonat mit Herrn Eberstein stellte sich herraus das es nicht so einfach ist, so nach dem motto ich kauf mal eben ein Soundmodul. So wie Herbert sagte probe Files bekommen angehört und wieder Telefoniert und ok gegeben.

 

Dann kamm die entscheidene Frage wie wollen sie die Sound schalten es gab zwei Versionen.

1. Nur ein kurze Taster Kontakt und der gespeicherte Sound läuft ab und gut ist.

 

2. Der Sound wird durch einen Taster ausgelöst solange dieser Taster gedrückt bleibt, bleibt der Sound im Mittelsegment und wiederholt sich immer wieder was man aber nicht merkt.

Nachdem los lassen des Taster läuft der Sound noch 1 bis 2 Sekunden nach. Ich habe für die Auslösung der Sounds geweils ein Relais mit an die Sonderfunktion angeschlossen oder Tastschalter an den Servos die das auslösen des Sounds einschaltet und auch wieder ausschaltet wenn die Sonderfunktion abgeschaltet wird.

 

Diese beiden schalt möglichkeiten gab es bei meinem Soundmodul.

Hier mal ein Link zu einen Video meiner Smit Bronko, wo alle Sound so geschaltet sind wie ich es in 2 beschrieben habe.

 

 

Alles andere kann auch ich nur sag ruf bei LE an besser geht es nicht,

aber vieleicht aheb wir ja etwas Licht ins dunkle gebracht.

Share this post


Link to post
Tigerfreund

Hallo Kollegen,

 

zuerst einmal Danke für Eure Hilfe und Eure Ratschläge. Herr Eberstein war natürlich meine erste Ansprechadresse und hat mir auch die Grundfunktionalitäten sehr freundlich und kompetent herübergebracht und das Modul läuft auch soweit. Bei den Sonderfunktionen hat es mit der Parallelschaltung zu Servos mit dem Esch-Modul leider nicht perfekt geklappt, so dass er mir weitere Module zur Verfügung gestellt hat, aber auch noch nicht perfekt.

 

Ich versuche einmal das Problem anhand der Heckklappe zu verdeutlichen:

Es gibt 2 Sounds (Öffnen und Schließen). Die Klappe wird durch verlängerte Servohebel bewegt. Ich habe kurz vor jedem Maximalausschlag des Servohebels einen Schalter angebracht der der den jeweiligen Sound abspielt.

 

Problem: Beim Herunterlassen der Klappe wird unter dem Maximalausschlag des Servohebels über den ersten Schalter das Herunterlassgeräusch (1) ausgelöst und wenn die Klappe dann fast unten ist wird natürlich das Hochziehgeräusch (2) geschaltet. Bei Wiederhochziehen ist es genau umgekehrt. Ich habe also immer beim vollständigen Bewegen der Klappe beide Geräusche was ja nicht Sinn der Sache ist. Ich hoffe ich konnte mein Problem annähern verdeutlichen?

 

Für Hilfe und Vorschläge wäre ich wirklich dankbar.

 

Ich habe schon überlegt auf ein Geräusch zu verzichten, aber das löst das Problem auch nicht.

 

Viele Grüße

Ralf

Edited by Tigerfreund

Share this post


Link to post
MatthiasSchumi

Hallo Ralf,

kannst mal ein Foto von Deiner Anordnung der Schalter und eine Skizze dazu mit der elektrischen Ansteuerung einstellen? Ich hab's noch nicht ganz verstanden.

Gruß

Matthias

Share this post


Link to post
Tigerfreund

Hallo Matthias,

 

der Sound wird ganz einfach durch einen Kontakt des passenden Kabels mit dem Massekabel ausgelöst und läuft dann ab.

 

In der Nähe des einen (die Gruben hat 2 Heckklappenservos) Heckklappenservoarms (was für ein Wort) habe ich 2 Schalter, einen beim fast maximalen Servoausschlag (hinten) für den Sound 1, einen beim entgegengesetzten fast maximalen Servoausschlag (vorne) für den Sound 2.

 

Das Problem ist, dass ich bei der maximalen Servobewegung die ich für die Heckklappe auch benötige nach einander beide Schalter betätige und damit immer beide Sounds auslöse.

 

Viele Grüße und Danke für Deine Hilfe

Ralf

Share this post


Link to post
Kapitän Odin

Am besten du machst mal ein Foto davon oder Zeichnung.

 

Wie sind die Sound programmiert? Kannst du sie überhaupt einzeln ansteuern bzw. Abrufen. Hast du vor dem Einbau eine trocken Übung gemacht.

 

Nicht das bei jedem auslösen beide abgerufen werden.

Share this post


Link to post
MHaussmann

Ich kann mir das so ähnlich, wie mit 2 Endschaltern vorstellen.

 

Was Du brauchst wäre eine Funktion : Schalter ein - Sound läuft einmalig ab und bleibt dann stumm. Nach dem Schalter aus, kann man den Sound erneut beim nächsten Schalter ein wieder abspielen.

 

Unschön ist da dann allerdings das Einschalten des Modells, weil da dann immer der Klappe Schließen Sound abläuft (Der Schalter steht ja auf ein, wenn der Strom kommt). Danach würde es ja korrekt funktionieren.

 

Martin

Share this post


Link to post
Guest anton9952

Hallo Kollegen,

ich kann mich bezüglich Soundmodul von LE-Elektronik den positiven Meldungen nur anschliessen. Bei mir war das Aufladen des Zusatzgeräusches " Möwengeschrei " auch kein Thema.

Zum Thema öffnen und schliessen der Heckklappe würde mir folgende Lösung einfallen.

Damit die Geräusche nur beim Öffnen bzw Schließen zu hören sind könnte ich mir eine Art Kurvenscheibe am verlängertem Servohebel vorstellen die

mit den geigneten Ausnehmungen ( Nasen ) die Abnehmer (Taster ) ansteuern. ( Öffner bzw. Schliesser ) Die Kurvenscheibe sollte so konstruiert sein dass bei geschlossener / geöffneter Heckklappe die Taster nicht durchschalten , jedoch auf den Auf und Zu - Wegen .

Vielleicht habe ich einen Denkfehler aber nach meinem Dafürhalten müsste es funktionieren . ODER ???

Share this post


Link to post
Tigerfreund

Hallo Kollegen,

 

vielen Dank für die rege Anteilnahme an meinem Problem.

 

Wie ich schon sagte, wird jeder Sound mit einem eigenen Kabel ausgelöst. Einen Funktionstest habe ich selbstverständlich gemacht: Das Soundmodul ist OK.

 

Das Problem beim Schalten ist tatsächlich dass der Sound nicht einmalig abläuft, sondern der Zwischenteil des Geräuschs immer weitergeht und erst bei Stromweg der Endteil abläuft. Mit nur einem Sound wäre das kein Problem, da könnte der Hebel quasi im Vorbeigehen immer den Sound kurz starten und gut wäre es. Aber bei zwei Sounds bräuchte ich so etwas wie einen Umschalter.

 

Die Idee mit der Kurvenscheibe muss ich mal durchdenken und vielleicht einen "Prototypen" aus Karton basteln und dann geistig ausprobieren.

 

Vielen Dank - für weitere Ideen bin ich natürlich immer noch offen.

 

Viele Grüße

Ralf

Share this post


Link to post
ManfredBochum

Ich versteh das Problem immer noch nicht.

Mach mal ein Bild

Share this post


Link to post
Guest anton9952
Hallo Kollegen,

 

vielen Dank für die rege Anteilnahme an meinem Problem.

 

Wie ich schon sagte, wird jeder Sound mit einem eigenen Kabel ausgelöst. Einen Funktionstest habe ich selbstverständlich gemacht: Das Soundmodul ist OK.

 

Das Problem beim Schalten ist tatsächlich dass der Sound nicht einmalig abläuft, sondern der Zwischenteil des Geräuschs immer weitergeht und erst bei Stromweg der Endteil abläuft. Mit nur einem Sound wäre das kein Problem, da könnte der Hebel quasi im Vorbeigehen immer den Sound kurz starten und gut wäre es. Aber bei zwei Sounds bräuchte ich so etwas wie einen Umschalter.

 

Die Idee mit der Kurvenscheibe muss ich mal durchdenken und vielleicht einen "Prototypen" aus Karton basteln und dann geistig ausprobieren.

 

Vielen Dank - für weitere Ideen bin ich natürlich immer noch offen.

 

Viele Grüße

Ralf

 

Hallo Ralf,

ich baue auch die B. Gruben und verwende das LE - Soundmodul. Habe elektrisch soweit alles verdrahtet und darf sagen es funktioniert bestens.

Allerdings steuere ich die einzelnen Sounds noch über die Fernsteuerung MC 19s von Graupner " händisch " an. ( 16 K Nautic Schaltbaustein samt Zusatzschalter bzw Taster ) Daher finde ich Deine Idee das Schliessen / Öffnen der Heckklappe direkt als Auslöser des dazugehörenden Sounds zu verwenden echt gut.

Und so ,wie schon erwähnt bin ich auf die Lösung mit der " Kurvenscheibe " gekommen . Diese darf aber über eine kurze Nocke nur kurz den Taster zum Schliessen betätigen . ( am Anfang des Weges, einmalige Soundauslösung )

Nachdem in der Gruben zwei verlängerte Servoarme die Klappe betätigen könnte man einen Arm zum Öffnen und einen zum Schliessen verwenden - denke ich .

Vielleicht wäre sogar eine Lösung mittels Reed - Kontakte samt Magnete etwas einfacher . ( Magnet am Arm montiert streicht am Reed Kontakt vorbei und schaltet Minus durch )

Auch das Aufholen der FIDI mittels Schlitten könnte man so soundmäßig ansteuern - denke ich.

 

MFG

ANTON

 

Ps . Wie weit bist Du mit dem Bau Deiner Gruben . Hätte einige Fragen dazu .:keineIdee:

Edited by anton9952
Zitat und Beitrag zusammengeführt.

Share this post


Link to post
Tigerfreund

Hallo Kollegen,

 

vielen Dank für Eure Vorschläge!

 

Ich habe die Sache noch einmal durchdacht und bin zur Erkenntnis gekommen, dass ich mit meinen nicht vorhandenen Elektronikkenntnissen nicht weiter komme. Ich bräuchte einen Baustein der bei Auslösen eines Kontaktes nicht nur das Soundmodul auslöst sondern einen zweiten Weg schaltet und beim nächsten Auslösen wieder zurück - einen Wechselschalter. Vielleicht gehe ich am Wochenende einmal zu Conrad und lasse mich beraten oder ich gebe diesen Weg auf.

 

Dann warte ich entweder auf das passende ESCH-Modul von Herrn Eberstein, oder ich verzichte auf einen Sound und löse den Öffnen-Sound eben auch beim Schließen aus (es hört wahrscheinlich sowieso niemand den Unterschied). Diese Lösung kriege ich mit zwei Schaltern in jedem Fall hin.

 

Nochmals vielen Dank

Ralf

Share this post


Link to post
Torsten

Hallo Ralf,

 

das wird tückisch, wenn Du "mechanisch" zwei verschiedene Sounds abspielen möchtest.

Du müsstest ja dann über das Nockenwerk die Drehrichtung unterscheiden können, ob die Klappe öffnet oder schliesst.

Geht wohl auch zu lösen, mit Rasten und Mitnehmern... aber wird sicher ein Meilenstein deutscher Ingenieurskunst.

 

Ich würde in Deinem Fall nur einen Sound nehmen und einfach nur die beiden Endstellungen abfragen:

 

-> Klappe offen oder geschlossen (einer der Schalter belegt) -> Sound aus

-> Klappe unterwegs (beide Schalter nicht belegt) -> Sound an

 

Das dürfte lösbar sein.

Mikroschalter haben ja meist Wechselkontakte, einfach die Öffner in Reihe schalten.

 

Ansonsten wird´s wohl elektronisch.

 

Grüße

 

Torsten

Share this post


Link to post
MatthiasSchumi

Hallo Ralf,

ich denke es wäre für alle hilfreich wenn Du ein Foto von Deiner Anordnung und/oder eine Skizze dazu machen könntest.

Du wirst Dich wundern wie dann die konkreten Ideen kommen.

Gruß

Matthias

Share this post


Link to post
Arno Hagen

Du wirst Dich wundern wie dann die konkreten Ideen kommen.

 

Das kann ich bestätigen. 1 Bild erklärt mehr als 1000 Worte!

 

So ganz verstanden habe ich das Problem nämlich auch noch nicht...

Share this post


Link to post
Frank Andrees

Hallo Ralf,

mir Diener jetzigen Lösung wird es sehr aufwendige werden, eine saubere Ansteuerung zu finden.

Dein Lösungversuch über ein Servoparallelkabel war schon der richtige Versuch. Ich weiß nicht, was du für einen Schaltbaustein verwendest hast, aber mit den Bausteinen sehe ich da auch Probleme

Wenn Du die heckklappe über einen Schalter ansteuerst, würde ich folgendes Teil benutzen.

Damit schaltest Du jeweils die einzelnen Soundeingänge auf Masse. Wenn du dann am Ende des Servohebels für die Heckklappe noch einen Öffner in die Leitungen einbaust, wird der jeweilige Sound beim kompletten Öffnen oder Schließen abgeschaltet.

 

Falls Du nicht genau verstanden hast, wie ich die Schaltung meine, dann kann ich auch gerne eine Zeichnung machen.

 

Mit freundlichen Grüßen

 

Frank

Share this post


Link to post
Tigerfreund

Hallo Frank,

 

des sieht sehr gut aus und könnte die Lösung meiner Probleme sein. :)

 

Dazu eine Frage: Für die Heckklappe sind schon 2 Servos parallel geschaltet. Geht das von der Spannung usw. her auch mit 3, oder bekommt dann mein Empfänger evtl. Probleme?

 

Viele dankbare Grüße

Ralf

Share this post


Link to post
Tigerfreund

Hallo Kollegen,

 

anbei ein Bild meines Problems (das sich mit dem Vorschlag von Frank hoffentlich bald lösen wird - habe so einen Umschalter soeben bestellt)

post-9004-1419862936,2363_thumb.jpg

 

Und hier ein kleines Schaubild des derzeitigen Zustandes:

post-9004-1419862936,2963_thumb.jpg

 

Viele Grüße

Ralf

Share this post


Link to post
Frank Andrees

Hallo Ralf,

sollte eigentlich kein Problem mit dem Strom geben. Ich weiß allerdings nicht, wie bei Dir die Stromversorgung realisiert ist.

Wenn du an Deiner Fernsteuerung noch Kanäle frie hast und die Schalter darauf zuweisen kannst, kannst du auch eine anderen Kanal nehmen und brauchst kein Parallelkabel.

 

Mit freundlichen Grüßen

 

Frank

Share this post


Link to post
Guest anton9952

Hallo Frank,

Danke, könnte klappen mit diesem Teil. Man muß ihn nur etwas umkonstruieren auf kurzen Momentkontakt sonst wird der Sound bei bereits geöffneter / geschlossener Klappe immer wieder abgerufen. Sollte aber zu realisieren sein.- Danke - Super Info !

Zum Thema Schutzgitter BSR kann ich nur anfügen dass bei der 20m Klasse zur Vermeidung von Treibgut etc. eine Konstruktion in Form eines "H" mit zweitem Querbalken aus ziemlich starkem Flacheisen angeschraubt sind. ob bei der Gruben ebenso ???

MFG

ANTON

Share this post


Link to post
Frank Andrees

Hallo Anton,

daher habe ich ja vorgeschlagen, am Heckklappenservo jeweils am Ende des Weges einen Mikroschalter als Öffner anzubringen. Wenn das Servo die Klappe komplett geöffnet hat, wird der Weg vom Soundmodul zur Masse geöffnet und der Sound hört auf.

 

Mit freundlichen Grüßen

 

Frank

Share this post


Link to post
Tigerfreund

Hallo Frank,

 

ich habe so ein Teil bestellt (kann man sicher immer mal brauchen), aber ich glaube, nach längerem Nachdenken, es wird nicht funktionieren damit 2 Sounds zu steuern, da ich immer bei einem kompletten Servoweg beide Sounds auslöse.

 

Ich habe jetzt die beiden Schalter in Serie geschaltet und mich auf einen Sound für das Heben und Senken entschieden. Gefällt mir zwar nicht, aber im Moment die einzige Lösung die geht. Vielleicht fällt mir/uns ja noch etwas anderes ein.

 

Viele Grüße und nochmals Danke

Ralf

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.